+4
Awaiting User Response

Flanders freezes at 48% when loading

RVK 3 weeks ago in PC / Windows • updated by Thomas 5 days ago 14

Game freezes at 48% every time I try to connect to Flanders. I've tried reinstalling the game but it did not work. No problems connecting to other maps.

Game Version:
286.9410
Reproduction steps:
Join any game that is running Flanders
Crashes/Freezes
Awaiting User Response

What are your system specs?

here are my specs: https://pcpartpicker.com/list/J68GCy

I'm running on Windows 10 64bit

Experienced the same thing tonight.


Running Windows 10 64bit


CPU: Ryzen 1500x

GPU: GTX 1060 6GB

RAM: 16GB DDR4


game is installed on a 500GB SSD

same here

crashes at 48% 

all other maps are fine

reinstalled game but didnt work


          Windows 10 64bit

CPU: i7 7700k

GPU: Asus ROG-STRIX-GTX1070-O8G-GAMING

RAM: 16GB DDR4


Might help to create a .dmp file via Task Manager when the game freezes and then share the file (compressed/zipped) via Google Drive, Dropbox, WeTransfer, etc.


  1. Game freezes at 48%
  2. Alt-Ctrl-Delete and open Task Manager
  3. Right click on the 1914-1918Series.exe
  4. Select the Create Dump File (Note down where it's created)
  5. Compress/Zip the 1914-1918Series.DMP file
  6. Upload the file onto WeTransfer, Google Drive, etc.
  7. Share the link for the file here.

There are way more players affected, than this ticket might suppose. Plz fix.

The error only appears if "Level of Detail Distance" is set to "Ultra". On "High" or lower, Flanders loads successfully.

Set it to medium and got stuck at 48%

Also on low? Maybe it is dependant on GPU memory...

Setting every setting to low makes it load.

I had Level of Detail distance on High and so far it worked for me , But today it stucked all the time .

I Set it to Medium and it was fine .

On low it also worked 

What is the problem here ?!

And is there any chance that it will be fixed soon ?!

Sounds like a buffer overflow to me somehow. Dependant on your graphics card, you have to lower your settings, so that the overflow does not occur. Should be enough input for the devs now ;-)